when I enable the joint inverse kinematics mode and not the hybrid mode, the robot joints will not fall due to gravity

Typically: "How do I... ", "How can I... " questions
Post Reply
LZG
Posts: 2
Joined: 15 Dec 2019, 02:42

when I enable the joint inverse kinematics mode and not the hybrid mode, the robot joints will not fall due to gravity

Post by LZG »

In the tutorial of redundantRobot.ttt, when I enable the joint inverse kinematics mode and not the hybrid mode, the robot joints will not fall due to gravity. In my own scene, the inverse kinematics mode is also enabled without the hybrid mode, and the robot joints But it will fall because of gravity, why?I want to use an external controller to control the robot, so I do n’t want to enable hybrid mode.

coppelia
Site Admin
Posts: 7911
Joined: 14 Dec 2012, 00:25

Re: when I enable the joint inverse kinematics mode and not the hybrid mode, the robot joints will not fall due to gravi

Post by coppelia »

Hello,

so you want to have a kinematic model of the robot? i.e. not use dynamics? In that case, you need to set your shapes to static and non-respondable. Normally, when importing shapes, they will be static and non-respondable by default.

Or do you want your robot to be dynamically enabled, and be controlled in position from an external application? In that case, your joints need to be in force/torque mode, the motors enabled, and the control loop also enabled. Then you can set the desired joint angles with sim.setJointTargetPosition

Cheers

Post Reply